This is a public Discussion Forum  public

Topic

    psusound
    UR4D+ Firmware Update
    Topic posted August 1, 2012 by psusoundNovice 
    380 Views, 7 Comments
    Title:
    UR4D+ Firmware Update
    Description:
    OK, first off, I am running my system set up as automatic IP, since I am am using a Dolby Lake Processor with Dante, Dante needs to run with auto IP. I am running 12 UR4D's, and have always just done the scan on the units at every gig. I have not used WWB. I would like to start using WWB6, but appears I need to update firmware before I can do that. So, I am trying to use WWB5 to update firmware. I have the ethernet port selected, go into live mode, but no recievers show up. Seems as though others had bad luck with auto IP, unless you have suggestions, guess I will assign IP's to all the units so I can hook up WWB5 to do the firmware update, switch back to auto IP, and see if I can connect with WWB6. Would really like to keep everything auto IP and on the same network. Would hate to keep having to switch IP's on the laptop.

    Any help?

    Answer

     

    • Sam Drazin
      Hi Chris,

      There is no reason that WWB5 would not be able to discover devices that are set to Auto IP mode. One strange behavior I have seen in WWB5 is that you need to restart it after having selected the proper network interface in order to discover devices on that network. Perhaps the following steps will help you out in this case?

      Assumptions:
      - DHCP server (router, or managed switch of sorts) is connected to all devices (this could be tested by pinging all devices at their current IP addresses to verify a network connection can be made)
      - All devices are on "DHCP" (Automatic) mode in their networking menus

      Steps
      - Launch WWB5 and enter Design mode (grey background)
      - From the Devices menu, select "Configure Ethernet Ports..."
      - Ensure that you have selected the proper network interface that your devices are connected to (to verify this, ensure that the IP address is on the same subnet as that of your auto-assigned devices).

      - WARNING: be sure that only one of your computer's network interfaces is connected to that subnet. If you have a WiFi and hardwired network connection to the same subnet, this could cause problems. In that case, disable the network interface that you are not actively using to connect to the gear.
      - Press OK to apply changes.
      - Restart WWB5.

      This will ensure that WWB5 is looking at the right network interface. If all other things are properly set up (network topology is sound, DHCP server is active and functioning without restrictions/rules applied within its interface, all devices' network jacks and connecting cables are functional, etc), then you should be good to go.

      Let me know if that helps.

      Thanks,
      -Sam
    • psusound
      Thanks Sam, I will try at the gig tonight. I am wondering if the issue was since I was plugged right into the switch, which is just an 8 port netgear switch. Wonder if I connect wirelessly through the router if that would act as the dhcp server. The address being shown is 0.0.0.0 when i tried to connect to WWB6, and showed me a green light, but no devices. All of the addresses on the UHFR units are 169 address. But under network properties, the computer showed a 169. address. I will report back. Thanks for the help

      Will the firmware update wipe out my settings and naming?
    • Sam Drazin
      Not sure about that to be honest, but I don't think so.

      With regards to your comments of the address being shown as "0.0.0.0", is this the IP address on the device you are seeing? Or this this the IP address of the subnet selected within WWB6 (Preferences > Network)? The reason I ask is that this could be a clue as to what is going on...

      Anyways, give my steps a shot and let me know how things progress. Hope to hear some good news!

      Thanks,
      -Sam
    • psusound
      OK, so in WWB the IP shows 0.0.0.0. But if I go to properties of the adapter, it shows a 169. address. The switch I am using is a Netgear GS108, I believe it is unmanaged, so this might be the issue? If I do the firmware by directly connecting to the receivers, then try to connect to WWB6, would I still run into problems?
    • buhmanb
      Hi Chris,
      I have seen this kind of behavior on Windows 7 and Vista operating systems.
      Example Setup:
      1. PC's network settings configured to "Obtain IP Address automatically" - and connected to a network with NO DHCP server
      2. PC indicates that it has "fallen back" to a link local IP address - such as : 169.254.245.183 with Subnet mask 255.255.0.0
      3. UR4 has also "fallen back" to a link local IP address - such as: 169.254.99.16 with Subnet mask 255.255.0.0
      4. PC can "ping" the UR4 - so we know the network should work.

      Symptoms:
      5. WWB5 Menu > Devices > Configure Ethernet Ports ... Dialog shows IP address as 0.0.0.0 with Subnet mask 255.255.0.0
      Also WWB6 Menu > Tools > Preferences > Network Tab - shows the IP as 0.0.0.0.
      6. Going to "Live Mode" in WWB5 does not discover the device - potentially indicating alerts "SNet: No devices"
      7. WWB6 also does not "discover" the UR4

      Work Around:
      1. Set a Static (aka Manual) IP Address on the PC such as:
      IP: 169.254.2.2 / Subnet mask: 255.255.0.0
      2. WWB5 Menu > Devices > Configure Ethernet Ports ... Dialog shows IP address as 169.254.2.2 with Subnet mask 255.255.0.0
      Also works for WWB6
      3. WWB5 can now able to go to "Live Mode" and discover the UR4 devices. Can perform FW Update. Then quit WWB5
      4. WWB6 can now discover the UR4 devices.

      Like I said - I've seen this with Windows 7 and Vista. Have not seen this with other OSs but it might also happen.

      I hope that helps!!
      -Brian
    • psusound
      Awesome, got it to work. Although only got it to work with a wired connection, keep getting the 0.0.0.0 IP for the wireless connection even though I went in and put in a static IP. Both WWB5 and 6 worked, didn't even do the firmware update, WWB6 works. Will update firmware AFTER the gig, haha. Not gonna take the chance before the gig today. Now, just have to get familiar on WWB6, very different than WWB5. Thanks for the help, will look on here to get some pointers on using WWB6.
    • Rick Waller
      This problem is occurring because you are using a switch, rather than a router. Since there is no DHCP server that hands out IP addresses, it does not work reliably. If you change to a router, the DHCP addressing would work every time.

      Cheers,

      Rick

     

    © 2009-2014 Shure Incorporated All rights reserved.
    • Privacy
    • Powered by RightNow