This is a public Discussion Forum  public


    UR4D's no longer available
    Topic posted August 2, 2013 by bfluganCompetent 
    414 Views, 9 Comments
    UR4D's no longer available
    I'm having this problem only with the most recent version of WWB6 ( I can not see any of my 10 UR4D's. However, I can see my 12 units of PSM-1000. I can ping the units and see them in windows command window. And if I roll back to a previous version of WWB6( I have no problems.

    All units and computer are set for a manual IP address from to with a subnet mask of There is no DHCP server on the network and this has always been rock solid in the past with no problems. When checking the network adapter info inside of WWB6 it says the subnet mask is It is set to in windows IP config. Not sure what's going on there.

    Any ideas?

    Hardware is below:
    9 x UR4D L3
    1 x UR4D H4
    1 x AXT630
    1 x AXT600
    3 x UA845
    4 x PSM1000 G10
    4 x PSM1000 J8
    4 x PSM1000 L8

    Also on network:
    9 x Senn EM3732-II

    Mac Mini running Bootcamp window XP Pro
    2.39 GHz
    2 GB of Ram




    • buhmanb
      Thanks for reporting and describing this problem so clearly. I can reproduce the problem in our lab.

      The changes in to add Windows 8 support seem to have broken support of XP.

      Will work with the developers to get a fix ASAP.
      Will also see if there is a short term work-around.

    • bflugan
      Do you know if this is the case for any other operating systems?
    • bflugan
      One other thing I noticed not sure if it helps, in XP, 6.8 does not show up in the list of installed programs. You have to use the uninstaller in the Shure folder to get rid of it.
    • buhmanb
      I've personally tried brief checks with:
      Win XP - Not discovering UR4, but discovers all other devices
      Win Vista - OK
      Win 7 - OK
      Win 8 - OK
      MacOS - 10.6 (Snow Leopard) - OK
      MacOS - 10.8 (Mountain Lion) - OK

      I will follow up with the WWB development & QA team and post if there are any other OS variations with this problem, and if there are any ways to work-around the issue.

      Yes - WWB6 not showing up in the Control Panel list of programs is a known issue and is scheduled to be fixed. Using the uninstaller from the Shure folder is the best way to uninstall at this time.

      Thanks again for helping make WWB6 a better program!
    • buhmanb
      An update:
      The developers identified the root cause of the problem: In the changes to support Win8, WWB6 started using a Windows API to access network settings that is not fully supported on Win XP.
      They have a fix that we'll be testing on all OSs before releasing a patch.

      So this problem only affects users running Win XP.
    • jmack
      HI Guys
      running a WWB6 class here and had three users with WinXP SP3. WWB6 v6.8.0.40 would not discover UR4D's on two out of the three PC's (all Dells). Had to roll back the remaining two to v6.6.1.13 to fix.

      So definately seems like XP support is broken in Didnt have time to work out why the third XP machine worked when the other two did not.

      Hope this helps.

    • buhmanb
      Thanks much! Yes, this issue is specific to WinXP, any service pack, any hardware platform (Dell, HP, etc..).

      William's description helped us find the problem very quickly. The Windows API used to determine the Subnet Mask of a network adapter was returning some "junk" values. Sometimes those junk values would eek by and work. The protocols used to discover & control UR4 devices are more susceptible to this problem. Thus Axient, ULXD and PSM1000 discovery worked better.

      We found the Windows API documentation indicated this specific API only works starting with Windows Vista.
      The developers now have a method that will work for all supported OSs.

      We're working on approving & releasing a patch asap.

      In the meantime rolling back to is the best solution for WinXP users. All other OSs should be fine with

    • robinno
      I have the same problem:
      Mac OS x 10.8.4

      -Workbench can't see the UR4D.
      -WWB can't see the UR4D.
      -WWB can't see the UR4D.

      Workbench 5 it works


      UPDATE 08-08-2013 13:37:

      I update the UR4D form 1.5.. to 1.6 in Workbench 5 and after that i will work on 6.8.4
    • buhmanb

      FYI - WWB has been released: Downloads

      Same features & functionality as, just the Windows XP bug was fixed.


    © 2009-2014 Shure Incorporated All rights reserved.
    • Privacy
    • Powered by RightNow